您需要登录后才可以操作登录 | 立即注册
关闭
楼主
AppCan运营
  • TA的每日心情
    开心
    2018-6-6 14:54
  • 签到天数: 128 天

    连续签到: 1 天

    [LV.7]常住居民III

    [平台公告] AppCan应用Android10上适配问题汇总 [复制链接]

    843 0 发表于 2019-12-27 10:54:12

    本帖最后由 AppCan运营 于 2019-12-27 14:55 编辑

    亲爱的AppCan开发者:

           Android10出来已有些时日了,针对Android10AppCan官方也已做了相应的适配,目前就AppCan应用关于Android10上适配问题做下总结,如果您有遇到此问题,可按对应的方法进行解决。

    问题一:
    Android10上应用覆盖更新提示:未找到可执行应用问题
    110811oqeq9rc8xkc66ut9.png
    解决方案:可参照对应帖子方法。
    AppCan应用Android10上不能更新问题解决
    https://bbs.appcan.cn/forum.php?mod=viewthread&tid=81479
    (出处: AppCan交流社区)

    问题二:
    Android10上,应用提示:下载出错了,请重试!或者进入应用白屏。
    QQ截图20191227103042.png

    解决方案:
    打包时选择不加密,并且选择支持硬件加速,打出包可解决此问题。

    注:如若担心应用安全,可使用第三方加密工具进行加固,如:爱加密、梆梆之类的。

    问题三:
    Android10上应用内文档打不开(使用了uexDocumentReader插件)。
    解决方案:
    更新uexDocumentReader插件至4.4.5版本可解决问题。

    问题四:
    Android10上应用使用uexLocation插件定位,第一次可以定位,第二次就不能再定位,返回(5e-324,5e-324)。
    解决方案:
    更新uexLocation插件至4.4.6版本可解决问题。
    注:为了保证定位正确,本版本开始必须在config.xml中配置百度地图的key。具体办法参考uexBaiduMap插件文档:http://newdocx.appcan.cn/plugin-API/SDK/uexBaiduMap

    问题五:
    Android10上应用获取设备串号为:null。
    解决方案:
    更新引擎和uexDevice插件至4.4版本即可解决问题。
    注:如果是企业客户,有用到uexEMM插件的客户,此插件也需要更新至最新版本(V3:uexEMM-android-4.4.46;V4:uexEMM-android-4.4.125.1)










    主题:
    级别:游客
    发帖:
    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    快速回复 返回顶部 返回列表