您需要登录后才可以操作登录 | 立即注册
关闭
楼主
AppCan_小助
  • TA的每日心情
    开心
    2016-10-10 11:07
  • 签到天数: 66 天

    连续签到: 1 天

    [LV.6]常住居民II

    [社区活动] 11月24日 专家在线答疑的问题及答案整理 [复制链接]

    995 0 发表于 2016-11-24 15:28:08

          以下为今天(11月24日)专家在线答疑的问题及答案整理,下次的集中在线答疑时间为12月8日,欢迎到时提问~
         用户
      有几个APP是用4.0之前的版本开发的,如果移植到4.0的话,
            1、需要注意哪些事项,因为4.0变成单文件布局了。
            2、移植到4.0,那之前的插件方法是否需要改动。
            3、如果有相应的文档参考,请放出一个地址。谢谢。
      AppCan官方
           1、打包的时候注意一下,选择引擎的时候有提示公告。
           2.除了需要注意的那几个插件,其他的不需改动
           3.3.0文档和4.0文档是同时开发的

         用户
      使用listview添加列表如何使他横向排列而不是纵向
      AppCan官方:您好!官方的jsssdk里的listview方法不能实现横向,可以换个思路 其实就是tab,超出屏幕的部分,整个用滚动的

      用户
           IDE3.3的项目能否升级引擎度4.0打包?要注意什么?
      AppCan官方: 不能,只能用4.0的IDE。


          用户
       path = "wgt://";
            uexFileMgr.cbGetFileRealPath = function(opId, dataType, data){
                if (dataType == 0) {
                    localStorage.wgtpat = data;
                    appcan.locStorage.setVal('localStoragewgtpat',data);
                }
            }
            uexFileMgr.getFileRealPath(path);

    var localStoragewgtpat=appcan.locStorage.val("localStoragewgtpat");
    uexFileMgr(文件操作控件) ios 删除 uexFileMgr.deleteFileByPath(localStoragewgtpat); 删除不了

    uexUploaderMgr(文件上传管理控件)  上传不了  录音 Audio.amr
    uexXmlHttpMgr(跨域异步请求控件)offline : true 缓存不了!

    3.0的就没有问题 用4.0的插件就不行了!
      AppCan官方
      请问引擎是最新版本4.0的吗?4.0的插件要用4.0的引擎。

          用户
      1.现在不能在线打包吗(chorme下打包不出现打包界面,firefox下可以 )?
          2.百度插件中的open方法不指定打开地图的中心点,需要2次调用setSenter()方法;
          3.极光推送双击的事件没有触发呢?
      AppCan官方:
      1,清除缓存试试
          2、需要配合使用接口
          3、请具体描述一下问题,只看到了现像,无法定位是前端问题还是插件问题。





    主题:
    级别:游客
    发帖:
    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    快速回复 返回顶部 返回列表